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TLAForms Overview
TLAForms is a tool to convert existing IBMi spool files into high quality, professional forms.
When a new form is created, the form is associated with an existing IBMi spool file. Fields can
be created based on data within the spool file, and these fields can be placed on the new form
as text, bar codes and images.
Text, bar code and image objects may be static, meaning the data is the same every time the
form is generated, or the objects may use variable data. Variable data primarily comes from the
data from the IBMi spool file, but TLAForms also can use data retrieved from IBMi files by using
SQL Statements created within the form. These objects may also use Spool File Attributes
which are properties of the IBMi spool file.
Design Features:
Text
Bar codes (Linear and Two Dimensional)
Rectangles, Lines, Ellipses
Images
Overlays
Actions to show and hide objects or pages on the form
Backside Overlay for printing 2-sided forms
Templates
Variable Data Features:
Spool Data
SQL Data
Spool Attributes
Actions
After the form is designed, TLAForms uses an application referred to as the Monitor to generate
the form. The Monitor runs on a Windows Server. It monitors an IBMi output queue and
recognizes when a spool file is generated. When the Monitor recognizes that a new spool file
has appeared in the IBMi output queue, TLAForms will automatically generate your form using
data from the spool file.
Forms are generated as pdf documents that can be archived to the IFS, and the forms can be
automatically emailed, and/or printed. The properties for archiving, emailing and printing are set
within the form and these properties can also be variable utilizing the Variable Data Features
mentioned above.
Output Features:
Email
Print
Archive
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Three Steps to Produce a Form

1. Identify the
Spool File
2. Use spool file
data to design
the form.

3. Monitor
generates the
form when the
spool file goes
to ready.

The spool file used to create the form must have a device type of *SCS. If an existing spool file is *afpds
or *ipds, over-ride the printer files’ device type using the command:
OVRPRTF FILE(YOURFILE) DEVTYPE(*SCS)
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System Requirements
IBMi OS/400 version
TLAForms requires IBMi OS/400 version 5.3 or higher.

TLAForms Designer (Recommended Requirements)
Windows XP or higher
Processor:
3 GHz processor
Ram:
4 gb
Disk Space: 200 mb
Display:
1024 x 576 or higher resolution monitor
Java Version 1.7 or above - Installed automatically by TLAForms

TLAForms Monitor* (Recommended Requirements)
Windows Server 2003 or higher (Recommended) or Windows XP or Higher
Processor:
3 GHz processor
Ram:
8 gb
Disk Space: 200 mb
Display:
1024 x 576 or higher resolution monitor
Java Version 1.7 or above - Installed automatically by TLAForms
*Note: Recommended to run on a windows server, but can run on any pc.

Printing
IBMi
Postscript capable printers are required for printing. A device description must be created as
instructed by T.L. Ashford. See Create Device Description.

Windows
A windows print driver must be installed on the windows server when the TLA monitor is being
used. Postscript printers are not required.
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Components
TLAForms is comprised of two components: TLAForms Designer and TLAForms Monitor.

Forms Designer
The Form Designer is an interface that allows a form to be designed using data from a spool
file. A form is associated with an IBMi spool file, and fields can be created within the Forms
Software based on data in the spool file.
The fields can then be used as text, bar codes, and images in the forms designer. The form will
be generated as a PDF file to a location on the IFS, and the form may be emailed automatically
or printed.

Forms Monitor
The Form Monitor is responsible for generating the form. The Monitor is intended to be
executed on a Windows Server; however it may be run on any or several PC's
simultaneously. It monitors an output queue on the IBMi to recognize when a spool file is
generated.
The Monitor application 'watches' for an entry in the TLAFORM/TLAFORMDQ data queue on
the IBMi. When the Monitor recognizes that a spool file has been generated, the application will
automatically generate the form from the TLAForms software.

The TLAFORMDQ data queue must be added to the IBMi output queue where the spool file is
generated. To change your output queue to utilize the TLAForm data queue, use the following
command from and IBMi command line: CHGOUTQ(OUTQNAME) DTAQ(TLAFORM/TLAFORMDQ)
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TLAForms Designer
The Form Designer is an interface that allows a form to be designed using data from a spool
file. A form is associated with an IBMi spool file, and fields can be created within the Forms
Software based on data in the spool file.
The fields can then be used as text, bar codes, and images in the forms designer. The form will
be generated as a PDF file to a location on the IFS, and the form may be emailed automatically
or printed.

Signing On the Forms Designer
To create, edit, transfer or configure global settings, you must sign on to the TLAForms
Designer.

From the Windows desktop, double-click the TLAForms Designer icon.

The TLAForms Designer SignOn appears.

1. At the SignOn Screen, enter your IBMi Userid and Password.
2. Click Login.
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The Form Designer screen will display.

TLAForms User Manual

Designing Forms
Forms are created by selecting a spool file from an IBMi output queue. The spool file is used to
create fields to be placed on the form. Spool file data can appear on the form as text, bar
codes, and images. Additionally, these fields can be used to define any form attribute such as,
the PDF name, printer name, and email address to name just a few.

Form Objects
There are eight types of form objects that can be used when designing forms.
Text
Barcodes
Images
Rectangles
Lines
Ellipses
Overlays
Templates
All types of variable data are not available for all types of objects. For instance, Text can use all
types of variable data, whereas Lines and Rectangles can only use Actions to be shown or
hidden.

Variable Data
There are four types of data that can be used when designing forms.
Spool File Data
SQL Data
Spool File Attributes
Actions

Note: Click on the Object Types or Variable Data Types to navigate through this document.
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Managing Forms
Forms are created by selecting a spool file from an IBMi output queue. Then, fields are
assigned using static objects and variable data from that spool file. Previously created forms are
maintained in the Forms Directory.

Note: The Form Name in TLAForms is the name of the spool file on the IBMi.

Create New Form
To create a new form select File>New>Form
Click the drop down arrow to Navigate to the Output Queue containing the desired spool file.

Select the desired spool file, click Select.
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Edit Existing Form
Click the Open button

in the toolbar or select File>Open

Select the form to be edited.

Click Edit.

Save Form
Click the Save button
but will remain open.

in the Toolbar or select File>Save Form. The form will be saved,

NOTE: The form name is name of the spool file.

Close Form
Select File>Close Form to exist the form currently being edited.
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Copy Form
To copy a form, the copied version of the form must be associated with a new spool file. The
new spool file must have a different spool file name, output queue, or output queue library.
Select File>Open
Select the Form to be copied.

Click Copy.

Click the drop down arrow to navigate to the output queue containing the new spool file.

Click Select
Note: The new spool file must have the same page width and page length of the spool file that
was used to create the initial form.
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Rename Form
To rename a form, the renamed form must be associated with a new spool file. The new spool
file must have a different spool file name, output queue, or output queue library.
To rename a form, Select File >Open
Select the form to be renamed.

Select Rename.

Select the new spool file.

Click Select.
Note: The new spool file must have the same attributes of the spool file that was used to create
the initial form.
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Delete Form
To delete a Form, Select File>Open
Select the form to be deleted.

Click Delete.
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Designer Window
When a form is created or an existing form is edited, the Form Designer will display.

Form Designer Overview

Pages
Tool Bar

Rulers

Form
Layout

Margins

Properties
Grid

Navigator

The overview provides an outline of the terminology that will be used throughout this manual.
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Navigator
The Navigator is a list of objects on the form.
When an object is selected in the Navigator panel, it will be highlighted on the form, and its
properties will be displayed in the properties panel.

Property
Panel

Navigator

Using the Navigator
Use the Sort button to to re-order the objects on the form. Sort will sequence the objects in the
following order: boxes, circles, images, lines, text. Each object is then ordered based on when it
was added to the form.

NOTE: The Sort feature is a useful tool for selecting objects that overlap. For example, a text
object on top of a shaded box.

Use the Select All button

to select every object on the form.

Use the Locked option to prevent changes to selected objects. Items displayed in RED in the
Navigator are locked.
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Form Objects
Static and variable objects can be added to the layout. Each type of object has its own unique
properties to produce the desired form.

Text
Text objects can be static information typed into the Data field or variable information using
Spool File Data, SQL Data or Spool File Attributes.

Add Text
Click the Add Text

button in the toolbar.

Set properties. See Text Properties.
Select OK to place the Text object on the form.
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Change Text
Double click the text object, or select the object from the Navigator panel, and utilize the
Properties Panel to modify text properties.
The Text Properties will appear on right.

See Text Properties.
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Text Properties

Font

TLAForms supports a variety of built-in Fonts.
NOTE: For QUICKEST printing results, Courier, Helvetica and Times New
Roman Fonts are recommended.

Size

Font size in points.

Spacing

The space between lines of text (leading). This is used for multi-line fields.

Style

Fonts can be set to Bold or Italic, indicated with a check box.

Justify

Center or right align the text. The default is none (Left Aligned)

Rotation

Text can be rotated in 0, 90, 180, or 270 degree orientations.

Foreground

Color of the foregound for the text field,
selected from the Color Palette.

Background

Color of the background for the text field,
selected from the Color Palette.

Example: The Foreground property is set to white, the Background is set to black.

Action

Actions allow an object to show or hide an object, or replace actual data in the
object with different data. See Actions.
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Link

Hyperlinks can be applied to Text objects. Hyperlinks function in PDF
versions of the form only.

Data

The Type of Data can be Constant or Variable Data. Variable Data is data
from the Spool File, Spool File Attribute, or SQL. Right click to select variable
data or click the Spool Data or SQL Button.
Constant and variable data can be combined by typing the constant data and
selecting the variable data.
For Example: Invoice Number <!Invoice#!>
Where: Invoice Number is constant
<!Invoice#!>
is a spool file field.
Note: A multi-line Spool File Field cannot be combined with any other data.

Spool Data

Access fields created from spool file data. See Selecting Data from the Spool
File.

SQL Data

Create SQL Statements that will retrieve data from IBMi files.
File data retrieved from an SQL can be placed on the form as text, bar codes
and images. See SQL Data.
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Barcodes
Data can be added in the form of linear or two-dimensional Bar Codes, either from static data or
from inserted fields from the spool file.
TLAForms supports the most commonly used Bar Code types.

Add Barcode
Click the Add Linear Bar Code

button in the toolbar.

Select Properties.
Place object on form.

NOTE: 2-Dimensional bar codes have unique properties specific to the symbology. See 2Dimensional Symbologies.
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Change Barcode
Double click on the bar code object to utilize the Text Properties Window. Alternatively, single
click the bar code object, or select the object from the Navigator panel, and utilize the Properties
Panel to modify text properties.

Modify properties.

Barcode Properties
Properties

Symbology
Bar code symbology is set in the Bar code Properties DialogBox or the Bar Code Properties
Grid. The symbology is the method of encoding data into the bars and spaces that make up a
bar code. Some bar codes require specific data types or specific lengths.
If a bar code symbology has been selected, and the amount and/or type of data is incorrect, a
red "X" will be displayed over the bar code on form.
See Bar Code Symbologies
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Spool Data
Selects data from the spool file. See Selecting Data from the Spool File.

Ratio
Bar code ratio refers to the difference between the width of the narrowest bar of the bar code
and the wider bars. The ratio can be changed only on I 2 of 5 (1:2 or 1:2.5) and Code 3 of 9
(1:3, 1:2.5, or 1:2 - including the HIBCC variation). The ratio is changed in the Barcode
Properties DialogBox or the Bar code Properties Grid.

Check Digit
Check digits are calculations performed on bar code data and, generally, append to the end of a
bar code. Check digits help ensure the integrity of the data within the bar code. Some bar codes
automatically contain check digits.
For instance, the UPC-A or Code128-UCC Shipping Container Code. For these bar codes, the
check digit option is not displayed, but the check digit will be included in the bar code.
The Code 3 of 9 bar code is capable of having a mod43 check digit appended. The I 2 of 5 bar
code is capable of having a mod10 check digit appended. When selecting either of these bar
code symbologies, the option to utilize the check digit will be displayed.

Human Readable
Selecting Human Readable for a bar code will cause the data being encoded in the actual bar
code to print as text. Please note, by selecting the human readable, the font used will default to
a set size and the text will print beneath the bar code. If the human readable is required to print
in a different font, place the "human readable" on the form as a text object.
See Text .

Rotation
Bar codes can be rotated in 0, 90, 180, or 270 degrees using the Rotation feature in the
Barcode Properties DialogBox or the Bar code Properties Grid.
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Height
Bar code height increments are made in tenths of an inch.

Narrow Bar Width
Narrow Bar Width measurement refers to the width of the narrowest bar in a bar code. The
width of the narrowest bar is measured in mils and also referred to as a bar code's X-dimension.
The overall width of the bar code is ultimately determined by the narrow bar width.

Action
Actions allow an object to show or hide an object, or replace actual data in the object with
different data. Actions can be applied to a linear bar code object only in the linear bar code
properties window. To access the linear bar code properties window, double click the bar code
object. Also See Actions.

SQL Data
Create SQL Statements that will retrieve data from IBMi files. File data retrieved from an SQL
can be placed on the form as text, bar codes and images. See SQL Data.

Link
Hyperlinks can be applied to linear bar code objects. Hyperlinks function in the PDF version of
the form only.
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Barcode Symbology
Bar code symbology is set in the Bar Code Properties DialogBox or the Bar Code Properties
Grid. The symbology is the method of encoding data into the bars and spaces that make up a
bar code. Some bar codes require specific data types or specific lengths.
If a bar code symbology has been selected, and the amount and/or type of data is incorrect, a
red "X" will appear. This is just to alert you of a potential error.

Codabar
As one of the symbologies competing to be the first grocery industry standard, Codabar was
beat out by the U.P.C. in 1973. However, it was soon adopted by the blood banking industry for
marking bags. Also, it was the first shipping symbology used by Federal Express. Codabar is a
numeric-only symbology with no check digit, a fixed ratio and a limit of 100 bytes.
Name

Check Digit

Ratio

Data

Length

Codabar

None

Fixed

Numeric

1-100

Code 128
Developed by Computer Identics in 1981 to produce compact alphanumeric barcodes, Code
128 can encode the complete 128 ASCII character set. To best utilize its double-density
capability (two values into one coded character), Code 128 offers three choices of character
sets (Subsets). Each option allows for improved data flexibility or maximum efficiency.
Subsets
Code 128, Subset A
Code 128, Subset A converts pairs of values into single hex-decimal values. While this
conserves space, some barcode readers may not decode hex back to the original values.
Code 128, Subset B
Code 128, Subset B encodes each character as a single value. This makes Subset B the widest
of the three variations, but it is also the most flexible, allowing for the encoding of numeric
values as well as upper and lower-case alpha characters and punctuation marks.
Code 128, Subset C
Code 128, Subset C converts pairs of digits into single values. This noticeably conserves space,
however the symbology is limited to evenly paired numeric values. Some printers will either drop
the odd digit or add a zero as a prefix to meet this requirement.
Variations
Code 128, Subset C + FNC1 Prefix
This variant of Code 128, Subset C adds an unprintable ASCII value (Function 1) before the
data content. This conforms to the GS-1 requirements for barcodes using an Application
Identifier. GS-128 or UCC/EAN 128 uses the FNC1 to indicate that an identifier is being used.
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When scanned, an application can determine the function of the barcode after determining the
value of the AI.
(Example: FNC142012345 = 420 (Domestic Postal AI) + 12345 (Postal Code))
Code 128, Subset C + FNC1 Prefix + Modulus 10 Check Digit.
This variant of Code 128, Subset C is a special function barcode used for creating the
UCC/EAN Serial Shipping Container Code or SSCC-18. This barcode automatically adds a
calculated check digit to the original 19 digits passed to it.

Code128
Name

Subset / Type

Check Digit

Ratio

Data

Length

Code128A

A

None

Fixed

Hex

1-40

Code128B

B

None

Fixed

Alpha

1-40

Code128C

C

None

Fixed

Numeric

2-40

GS-128

Subset C + FNC1

Mod103

Fixed

Numeric

2-40

SSCC-18

Subset C + FNC1

Mod10/Mod103

Fixed

Numeric

19

UPS Ground

Subset C

Mod10

Fixed

Alpha

17

Code 39, Code 3 of 9
Code 39, or Code 3 of 9, was the first standardized barcode for industrial manufacturing and
shipping. The symbol’s high ratio and density make it suitable for printing on large cartons and
can easily be read by long-range scanners. Developed in 1982 by Intermec, Code 39 is still
widely used in part identification and shipping.
Code 39 is an alphanumeric symbology (upper-case only) with a variable ratio.
Variations
Code 39, 1:3 Ratio
This type represents the most common version of Code 39. The high narrow-to-wide ratio of
bars and spaces gives the symbol a high readability and durability.
Code 39, 1:2 Ratio
This type uses a lower ratio to increase density, allowing for the same data to use less space at
the sacrifice of some readability.
Code 39, 1:2.5 Ratio
The middle ground between the high and low ratio symbologies.
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Code 39, 1:3 Ratio w/ Mod43 Check Digit
This variation is the standard 1:3 high ratio barcode as the first, but a Modulus 43 check digit
function is added to confirm the symbol content. The Health Industry Business Communications
Council (HIBCC) requires this variation to produce their industry standard labels.

Name

Check Digit

Ratio

Code39

None

1:3

Code39

None

1:2

Code39

Mod43

1:3

Code39

None

2:5

Data

Length
1-40

A-Z,
0-9,$, %,
+,-, /, .,
space

1-40
2-40
2-40

Code 93
Originally, Code 93 was developed by Intermec to compete against Code 128 in 1982. Using
the same character set as Code 39, it could produce a more efficient alphanumeric symbol than
Code 128. However, Code 128’s double-density encoding mode could produce more efficient
numeric-only symbols.
Code 93 is an alphanumeric symbology (upper-case) with a max of 100 bytes and fixed ratio.

Code

Name

Check Digit

Ratio

Data

Length

Code93

None

Fixed

Alpha- Numeric

1-100

93 Check Digit Ratio Data
Length

EAN - 13
Founded on the principles of U.P.C., non-U.S. groups adopted the International Article
Numbering system in 1976. The main difference is the addition of another digit to the U.P.C.’s
12-digit symbol, to allow for an international number system. Like UPC, the first 6-8 bytes of the
encoded data identify the manufacturer of a product, and the remaining 4-6 bytes determine the
individual product.
Variation
EAN-8
Like UPC-E, this short-form is used when an EAN-13 would be too big for the product being
labeled. EAN-8 uses zero suppression to truncate the vendor ID and product number, the same
as UPC-E.

Name

Check Digit

Ratio

Data

Length

EAN-13

Mod10

Fixed

Numeric

12

EAN-8

Mod10

Fixed

Numeric

7
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Postnet
The United States Postal Service needed a system to quickly and inexpensively read encoded
Zip Codes. Optical Character Recognition systems could read printed postal codes then apply a
small label with the ZIP+4 postal code for more accurate routing.
Postnet is a numeric-only binary code that only produces a 5 or 9-digit symbol.
Name

Check Digit

Ratio

Data

Length

PostNet

None

Fixed

Numeric

5/9

Plessey
Originally created by Plessey Limited of Dorchester England, this symbology was developed for
use on grocery shelves and is now heavily used in library applications.
Plessey (also developed as MSI, Telxon, and Anker) is an alphanumeric (A-F only) barcode with
a fixed ratio.
Plessey Check Digit Ratio Data Length
Name

Check Digit

Ratio

Data

Length

MSI

None

Fixed

0-9,A-F

100

Plessey

None

1:2

Numeric

1-14

UPC - Universal Product Code
Adopted by the U.S. Grocery Industry in 1973, the Universal Product Code is now the most
commonly seen bar code symbol. It’s still in use today, but now called the GS-1 GTIN-12.
GS-1 oversees assigning of manufacturer ID numbers to its members, who in turn, assign
unique number to each of the products they produce.
The combined values, plus a check digit, become the U.P.C. for scanning at a point of sale
register.
Variations
UPC-A
This is the original UPC product standard, also known as the GTIN-12.
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UPC-E
For products too small for a full-sized UPC-A, a zero-suppressed version is available that
truncates the same data into 8 bytes.
Name

Check Digit

Ratio

Data

Length

UPC-A

Mod10

Fixed

Numeric

11

UPC-E

Mod10

Fixed

Numeric

10

UPCE-0

Mod10

Fixed

Numeric

6

UPCE-1

Mod10

Fixed

Numeric

5
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2-Dimensional Symbologies
Refer to Subtopics:

PDF-417
Add PDF-417
Click the Add 2-Dimensional Bar Code

button in the toolbar.

Select PDF-417
Select Properties.
Place on form.

Change PDF-417
Double click on the PDF-417 object to utilize the PDF-417 Properties Window. Alternatively,
single click the object, or select the object from the Navigator panel, and utilize the Properties
Panel to modify properties.
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PDF-417 Properties

Maximum Columns
Indicates the number of columns to encode a PDF-417 symbol. Increasing the number of
columns will produce a wider bar code.

Security Level
Data inside a PDF-417 is redundantly repeated to improve integrity. Higher values are more
secure, but increase size. Consult your PDF-417 specification for proper use of security level.

Element Width
Width of the narrow bar expressed in dots. Increasing the element width will increase the width
of the PDF-417 symbol.

Element Height
Height of the row expressed in dots. Increasing the element height will increase the height of the
PDF-417 symbol.

Truncate
In a PDF-417, this option omits the right row indicators and the stop pattern will be reduced to
one module width bar.

Insert Field
Selects Data from the Spool File. See Spool File Data.
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QR Code
In this Section

Add QR Code
Click the Add 2-Dimensional Bar Code
Select QR Code

Select Properties.
Place on form.

button in the toolbar.
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Change QR Code
Double click on the QR Code object to utilize the QR Code Properties Window. Alternatively,
single click the object, or select the object from the Navigator panel, and utilize the Properties
Panel to modify properties.

Modify properties.
QR Code Properties
ECC Level (Error Correction Capability) Level - Values are L, M, Q and H. The values
determine data redundancy to maintain integrity in case of damage.
Module Size (Magnification) - Element Size (affects overall size of the bar code)
Symbol Size Rotation - Rotates the PDF symbol to 90, 180 or 270 degrees.
Data Mode - Indicates types of data that may be used with the QR Code
Insert Field - Selects Data from the Spool File. See Spool File Data.
Check Digit
None

Data
Alpha-Numeric

Length
1-7000*
* max length depends on type of data being encoded.
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Check Digits
Check digits are calculations performed on bar code data and, generally, appended to the end
of a bar code. Check digits help ensure the integrity of the data within the bar code. Some bar
codes automatically contain check digits. For instance, the UPC-A or Code128-UCC Shipping
Container Code. For these bar codes, the check digit option is not displayed, but the check digit
will be included in the bar code.
The Code 3 of 9 bar code is capable of having a mod43 check digit appended. The I 2 of 5 bar
code is capable of having a mod10 check digit appended. When selecting either of these bar
code symbologies, the option to utilize the check digit will be displayed.
In this Section

Mod 10 Check Digit
TLAForms automatically calculates the MOD10 check digit on a number of barcodes as well as
human readable fields. However, it may be necessary to calculate this value manually or in a
separate program.

This example will use the data:
011597643

Add the Odd Position Digits.
Actual
Data

0

1

1

5

9

7

6

4

3

Position

9

8

7

6

5

4

3

2

1

3 + 6 + 9 + 1 + 0 = 19 (SUM1)
Multiply the Result times 3.
19 x 3 = 57 (SUM2)
Add the Even Position Digits.
4 + 7 + 5 + 1 = 17 (SUM3)
Add SUM2 to SUM3
57 (SUM2) + 17 (SUM3) = 64 (SUM4)
Subtract SUM4 from its next highest multiple of 10 (in this example, 70).
70 - 64 (SUM4) = 4
The resulting check digit is 4
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MOD 43 Check Digit
Some Code 39 data structures employ a Modulus 43 Check Character for additional data
security. The Check Character is the Modulus 43 sum of all the character values in a given
message and is printed as the last character value.
This example will use the data:
E598976987

Add the table values that correspond to the actual data
Actual Data

E

5

9

8

7

6

9

8

7

Value

14

5

9

8

7

6

9

8

7

14 + 5 + 9 + 8 + 9 + 7 + 6 + 9 + 8 + 7 = 82 (SUM1)
Divide SUM1 by 43
82 / 43 = 1 (with a remainder of 39)
The Check Character is the character corresponding to the value of the remainder (see Table
below), which in this example is 39, or “$”.
The complete Symbol data structure with Check Character ($) appended, would therefore be:
E598976987$

Table
Character

Value

Character

Value

Character

Value

Character

Value

0
1
2
3
4
5
6
7
8
9

0
1
2
3
4
5
6
7
8
9

A
B
C
D
E
F
G
H
I
J
K

10
11
12
13
14
15
16
17
18
19
20

L
M
N
O
P
Q
R
S
T
U
V

21
22
23
24
25
26
27
28
29
30
31

W
X
Y
Z
.
Space
$
/
+
%

32
33
34
35
36
37
38
39
40
41
42

41

42
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Images
Images must be imported before being available to be used on forms. See Import Image.
Once imported, images are stored in the IFS directory home\TLAFORM\Lgo. Once an image is
imported into the software, it is available to be used on any form.

There are two 'types' of images that can be used with your forms - an image and an overlay.
A image is any image you might place on the form whereas an overlay is an image that might
take the place of a pre-printed form. The image that makes the overlay is generally the size of
the entire form.
In
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Add Image
Click the Add Image

button in the Toolbar.

The Image Directory will display.

Scroll to choose the Image to place on form. The image will preview on the right.
NOTE: The image to be used must be imported into the forms software before being available to
be placed on a form. See Import Image. For optimum printing speeds, it is recommended that the
image be imported as near to the final printing size as possible.

Click Select to place image on form.
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Images Properties

X over

Over position in inches relative to the left edge of form.

Y down

Down position in inches relative to the top of the form.

Rotation

Orientation of the image on the form

Locked

Checking this box will prevent any changes to be made once this object is set.

Scale

Percentage of size of the original image. The image may be scaled proportionally
only. For optimum printing speeds, it is recommended that the image be imported
as near to the final printing size as possible.

Opacity

Opacity of the image. Lower opacity percentage causes an image to be more
transparent. Use this property to create a watermark effect for the image.

Action

Actions can determine if an object appears or is hidden. See Actions. Actions can
be applied to an image in the properties panel. To access the properties panel for
an image, click the image object to select. The properties panel for the image
object is displayed on the right of the design screen.

Link

Hyperlinks can be applied to Image objects. Hyperlinks function in the PDF version
only.
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Import Image
Click the Add Image

button in the Toolbar.

The Image directory will be displayed.

Click the Open button

and navigate to the location of the image to be imported.

Click Open to Add the image.
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Variable Image
Images may be variable using data from the spool file, SQL, or a Spool File Attribute to control
which image is output on the finished form.
Click the Add Image

button in the Toolbar.

The Logo Directory will display.

Check Variable Image

Right Click

Click the Variable Image box.

Right Click in the variable image field to select Spool Data, Spool File Attr, or SQL Statement
where the name of the logo will be derived.

NOTE: When images are generated variably, all images must be of the same type or extension.
TLAForms supports .bmp, .gif, .jpg, .png.
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Example - Variable Image from Spool File Field
This example describes how to output an image variably based on information from the IBMi
Spool File.
Create a Spool File field (company) that contains the name of the logo to be output.

ABC INC

This is page 1 from the spool file. The company field contains ABC INC
Click the page arrow to go to page 2.

ACME INC

The company field contains ACME INC
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For this example, two images will need to be added to the TLAForms software: ABC INC and
ACME INC. See Import Image

From the designer, click the Add Image
ACME INC images.

button in the toolbar to add the ABC INC and

ABC INC.jpg
ACME INC.jpg

Notice the two images (AMCE INC and ABC INC) have already been added to TLAForms.
Click Variable Image.
Right Click in the Variable Image field, select Spool Data then select the company field from
the spool file.
Click the logo extension drop down and select the type of graphic extension for the two
images.
In this example, the images are jpg.
Note: The image names used as a variable must have the same image type.
Click Select to place the Image on the form.
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Once the Image is placed on the form, use the page button to test the variable Image.

Page 1 The ACB INC company logo is displayed.

Page 2 The ACME INC company logo is displayed.

TLAForms User Manual

Overlays
Overlays are used to replace pre-printed forms. Overlays can be .pdf, .bmp, .jpg, and .png files
imported into TLAForms. Overlays can also be Templates created within TLAForms and used
on your form as an overlay. Overlays are similar to images with the exception that the overlay
cannot be rotated and overlays cannot be variable.
Overlays can be placed on the front of a form, or used on the backside of a form to create twosided output.
Templates are recommended when using overlays on a form. Templates will process faster
and will result in better quality than an overlay imported from a pdf, bmp, jpg, and png file.

Add Overlay
An Overlay is added to a form using the Overlay Tab on the Property panel as shown below.

Click the Overlay extension

button.
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The Overlay Directory will be displayed.

Choose an overlay from the directory. Click Select.

To import a new overlay, click the Open Folder
document or the image resides.

The Overlay will appear on the form.

and navigate to the directory where the pdf
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Overlay Properties
Overlay Properties are located on the Overlay Tab on the Property panel as shown below.

Overlay Name

Name of overlay being used.

X Over

Over position of image relative to the left edge of the form.

Y Down

Down position of the image relative to the top of the form.

Scale %

Percentage of size of the original image. The image will be scaled
proportionally.

Opacity

Opacity of the image (Transparency).

Backside Overlay

The overlay can be used on the back side of the form creating a 2-sided
form. To use the overlay on the backside, check the Backside Overlay
box.

Show Backside

If the overlay is being used as a backside overlay, checking the Show
Backside box will display the backside overlay on the form.
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Import Overlay
To Import an Overlay use the Overlay Tab on the Property panel as shown below.

Click the Overlay extension

button.
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The Overlay Directory will be displayed.

Click the Folder Button.

Navigate to select the document or image to be used as the Overlay.

Select Open.
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The Overlay Attributes window will be displayed.

Overlay Attributes

Overlay Name

The name of the overlay to be created.

Page Number

The page number from the document to be created as an overlay.

DPI

Dots Per Inch of the overlay to be created as an image. Valid values are:
72, 96, 200, 300, and 600.

Output Type

The type of image to be created as the overlay. The valid types are: jpg,
png, and gif.

Click Create.

Select the Overlays tab to choose the Overlay to be placed on the form.

Note: The recommended overlay type is a template. Templates process much faster and
will result in better quality. The best use of an overlay is tracing. See Trace Overlay.
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Trace Overlay
Overlays are not the recommended method to output forms, as they are slower and do not offer
the best quality. The preferred method is to create the form using objects such as Lines,
Rectangles, and Text to name just a few. This will make the form more flexible when placing
variable data within the design.

However, overlays are very useful when used as an outline to trace when creating a new form.
To trace an Overlay follow the steps below.


Import the existing PDF document as an overlay. See Import Overlay.



Place the overlay on the form. See Add Overly.



Trace the Overlay using Lines, Rectangles, Text and Images.

To see the progress of the form design, click the Overlay Tab and Check Backside Overlay.
The overlay will disappear from the design. Uncheck Backside Overlay. Repeat the process to
replicate the document.

Once the design is complete, uncheck Backside Overlay and clear the Overlay Name field.
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Templates
Templates are reusable static designs that can be inserted into a form or used on a form as an
overlay. When a template is inserted into a form, all of the objects from the template are
editable.
Templates can also be used on the form as an overlay. When a template is used as an overlay,
the template is placed on the form as a single object and cannot be edited within the form
design. Any modification to the source template, used as an overlay, affects every instance of
the template when used as an overlay on any form.

Create Template
Templates can be created as a new blank Template or they can be created by selecting objects
from within an existing form. They can consist of static objects only. Variables such as: Spool
File Data, Spool File Attributes, and SQL Data cannot be included within the template.

To create a new, blank template Click File>New>Template
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The TLAForms Designer opens in Template Mode.

Design the template in the same manner as a form. All object types are available: Text,
Barcodes, Images, Lines, Rectangles, and Ellipses. The only difference between designing
templates and forms is that templates may not include any variable data such as: Spool File
Data, Spool File Attributes, and SQL Data.
Enter a Template Name and Description using the property pane to the right of the design area.
Click the Save button

in the Toolbar or select File>Save.

The Template will be saved, but will remain open. The Status bar will display Template Saved.
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Create Template – From an Existing Form
To create a Template from an existing form, click File>Open and choose an existing form.

Select All

Click and drag to highlight objects to be saved in the template. In the example above, all objects
on the form were selected by clicking select all.
Right Click>Create Template
The create Template window will be displayed.

Assign a name for the Template, click Create.
The Template is created in the TLAForms Template directory and the template can be inserted
into other forms and/or used as an overlay on other forms.
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Edit Template
To Edit an existing Template, Click File>Open

Select the Templates Tab.
Click the Template to change.
Click Edit.
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Insert Template
Templates can be added to the form by inserting the template onto the form or by specifying the
template as an overlay.
When the template is inserted into the form, the objects from the template are imported directly
onto the form, and those objects are editable.
When the template is used on the form as an overlay, it assumes the properties of the overlay
and it is not editable. See Add Overlay.
To insert a template, open an existing form, Right Click at the position on the form where you
want to place the Template.

Select Insert Template.

The Template directory will be displayed.

Click Select.

Note: The template is placed on the form at the mouse position when the Right Click occurred.
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Use Template as Overlay
Templates are the preferred method when using an overlay on a form because they process
faster and typically result in better quality.
To use a Template as an Overlay, Click the Overlay Tab as shown below.

Click the extension

button to select the Template to be used as an Overlay.
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The Overlay Directory will be displayed.

Click the Template, then press Select.

The Overlay tab will be populated with the Template that was selected as shown below.

When using a Template as an Overlay, scale and opacity will have no effect.
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Lines
Draw horizontal and vertical lines on the form.

Click the Line button

in the Toolbar.

Move cursor, now appearing as crosshairs

, onto

the form.

Click and drag to draw line.

Once the line is drawn, release the mouse button.
The existing line can be moved, edited, copied, deleted or locked. Once locked the line cannot
be moved or changed until unlocked.

Tip: When drawing multiple lines to create a table, use the copy and paste function so that each
Line has the same properties. Then use Align feature to ensure that each line has the same
over/down position.
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Line Properties

Position
X over

Position of the left edge of the line measured from left edge of paper.

Y down

Position of the top edge of the line measured from top edge of paper.

Locked

Checking this box will prevent any changes to be made once this object is set.

Shape
Width

Width of the line

Height

Height of the line

Foreground Color of the line.
Action

Actions allow an object to show or hide an object. See Actions. Actions can be
applied to a line in the properties panel. To access the properties panel for a
line, click the line object to select. The properties panel for the line object is
displayed on the right of the design screen.

Link

Hyperlinks can be applied to Line objects. Hyperlinks function in the PDF
version of the form only.
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Rectangles
Draw Rectangles / Square on the form. Click the Rectangle button
Move cursor, now appearing as crosshairs,

in the Toolbar.

onto the form.

Click and drag to draw rectangle.

Once the rectangle is drawn, release the mouse button.

The existing rectangle can be moved, edited, copied, deleted or locked. Once locked the
rectangle cannot be moved or changed until unlocked.
Tip: When drawing multiple rectangles, use the copy and paste function so that each rectangle has the
same properties. Then use Align feature to ensure that each has the same over/down position.
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Rectangle Properties

Position
X over

Position of the left edge of the rectangle measured from left edge of paper.

Y down

Position of the top edge of the rectangle measured from top edge of paper.

Locked

Checking this box will prevent any changes to be made once this object is set.

Shape
Width

Width of the rectangle.

Height

Height of the rectangle.

Foreground

The color of the stroke of the rectangle.

Background The filled color of the rectangle.
Action

Actions allow an object to show or hide an object. See Actions. Actions can be
applied to a rectangle in the properties panel. To access the properties panel for
a line, click the rectangle object to select. The properties panel for the line
object is displayed on the right of the design screen.

Link

Hyperlinks can be applied to Line objects. Hyperlinks function in the PDF
version of the form only.
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Ellipses
Draw Ellipses / Circles on the form.

Click the Ellipse
onto the form.

button in the Toolbar. Move cursor, now appearing as crosshairs,

Click and drag to draw ellipse.

Once the ellipse is drawn, release the mouse button.

The existing ellipse can be moved, edited, copied, deleted or locked. Once locked the ellipse
cannot be moved or changed until unlocked.
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Ellipse Properties

Position
X over

Position of the left edge of the ellipse measured from left edge of paper.

Y down

Position of the top edge of the ellipse measured from top edge of paper.

Locked

Checking this box will prevent any changes to be made once this object is set.

Shape
Width

Width of the ellipse.

Height

Height of the ellipse.

Foreground

The color of the stroke of the ellipse.

Background The color of the fill of the ellipse.
Action

Actions allow an object to show or hide an object. See Actions. Actions can be
applied to an ellipse in the properties panel. To access the properties panel for
a line, click the ellipse object to select. The properties panel for the line object is
displayed on the right of the design screen.

Link

Hyperlinks can be applied to Line objects. Hyperlinks function in the PDF
version of the form only.
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Align
Objects can be aligned on the form by selecting the objects to be aligned, right clicking, select
Align> then select alignment method.
Objects can be aligned Left, Right, Top or Bottom.
Left

Aligns all selected objects to the left, relative to the left most objects selected.

Right

Aligns all selected objects to the right, relative to the right most objects selected.

Top

Aligns the top of all selected objects along the top border of the top most objects
selected.

Bottom

Width of the ellipse.

Distribute
Objects can be distributed across Horizontal or Vertical space on the form by selecting objects
to be distributed, right clicking>click Distributed>select distribution.
Horizontal

Distributes selected objects equally based on positions of left most selected object
and right most selected object.

Vertical

Distributes selected objects equally based on positions of top most selected object
and bottom most selected object.

Lock
Objects on the form can be locked to prevent changes.
Select object(s), right click, and select Lock/Unlock.
NOTE: Locked objects appear in RED in the Navigator. Additionally, when the cursor moves over
a locked object, a small red x will appear with the cursor that indicates the object is locked.

Zoom
Click the Zoom In button or Zoom Out button to magnify the view of the form, or Click on the
Zoom magnification button to select magnification.
You may also select View>Zoom>Choose zoom level.
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Test Printing
TLAForms can print to PostScript printers defined on the IBMi. The software can also print to
any printer connected to a Windows Server or the local PC.
When printing to an IBMi PostScript printer, a device description is required. To create a
device, see Create Device Description.
Select File>Test Print
NOTE: Before the form will print, a printer must be associated to the form.
By default, the printer is set to *NONE.

To select, change or display the printer, click Tools>Advanced Options> Printing Tab

Select the Refresh Printers button.
This will scan the IBMi for all PostScript printers. To scan for all available printers, IBMi and PC
printers, change Print Services to *All.
The results of the scan will be loaded into the Printer List.
If there are IBMi printers that do not appear in the list after Refreshing Printers, the printer is not
configured for postscript printing on the IBMi. See Create Device Description.

73

74

TLAForms User Manual

Printing Properties
Printer

IBMi Postscript printers are displayed using the name of the device created for the
printer.
If there are IBMi printers that do not appear in the list after Refreshing Printers,
the printer is not configured for Postscript printing on the IBMi.
See Create Device Description.

Windows Server printers are displayed using the following syntax:
Win: \\ServerName\PrinterName
Printers configured on a PC are displayed using the following syntax:
Win: PrinterName

Copies

Number of copies to be printed.
If copies is set to 0 (zero), TLAForms will automatically access the Copies
Attribute of the spool file to determine the number of copies to print.

Drawer

Drawer from which stock will be selected from the printer.
Refer to your printer manual to obtain the correct location of the drawer being
used.
To print to the drawer using the attributes of the spool file, enter <!DRAWER!>

Variable
Printer

There are three ways to achieve variable printing.
1

Spool Data
The program that produces the spool file writes the printer name to the spool
file. Then create a field from the spool file data for the printer name.
Click Variable Printer>Right Click the printer field and select Spool Data to
select the printer name field that was created from the spool file.

2

Spool Attribute
The program that produces the spool file overrides one of the spool file
attributes such as user data or form type with the printer name.
Click Variable Printer>Right Click the printer field and select Spool Attr to
select the spool file attribute that contains the printer name .

3

SQL Statement
Create an SQL statement to retrieve the printer from an IBMi database file.
Click Variable Printer>Right Click the printer field and select SQL Statement
that will return the printer name.
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Output
Mode

Print
Services

Determines how print jobs are generated. Output mode can be used to burst
printing of a form to different printers, or to burst printing of a form into separate
print jobs.
Normal

The form will be printed based on the entire spool file.

Off

The form will not be printed.

Per Page

The spool file will be burst, and the form is printed based on each
page of the spool file. If a spool file consists of 5 pages, 5 separate
print jobs are generated.

Field Name

The spool file will be burst based on data contained within a field
created in form design. If a field called <!Invoice#!> is created in
form design and chosen for output mode, the software will create a
new print job each time data within the <!Invoice#!> field changes.

The Printer Services options allow for printers list to be populated based on where
the printer is defined.
*ALL

Displays all printers configured on the IBMi as PostScript,
printers defined on Windows Servers and printers defined
on the PC being used.

IBMi Postscript

Displays only printers configured on the IBMi as PostScript
printers.

Local Windows

Displays only printers configured on the PC being used.

Windows Network

Displays only printer configured on the Windows network.

NOTE: Test Printing prints the form as it appears in the Forms Designer. Test printing utilizes
data from the spool file selected when the form was created.
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Generating Forms
Forms generated from the TLAForms software will automatically be generated as a PDF
document. The PDF documents are saved to an IFS location, and can be printed, and
automatically emailed.
Output Properties are set by clicking, Tools>Advanced Options
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Generating PDF
TLAForms automatically generates a PDF document of the designed form in the IFS. The PDF
properties such as the name, path, title author, subject and keywords, can be static or variable.
Variable properties can come from data in the spool file, spool file attributes or from an SQL
statement. To use variable data in these properties, right-click in the properties field.

PDF Properties
PDF Properties are set by clicking, Tools>Advanced Options

PDF Name

This is the actual name of the PDF document produced. Static or variable.

IFS Path

Location where the PDF document will be created. If the IFS path does not exist, it will
be created.

PDF Title

Title of the PDF document.

Author

Author of the PDF document.

Subject

Subject of the PDF document.
PDF Properties Continued
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Keywords

Keywords that may assist in searches.

Page Size

Page size of the PDF document. Select from a pre-set list.
A3
A4
A4_L
A5
A6
B4
B5
EXECUTIVE
LEDGER
LEGAL
LETTER
LETTER_L
_11X17

11.7
8.3
8.3
5.8
4.1
9.8
6.9
7.0
11.0
8.5
8.5
8.5
11.0

x
x
x
x
x
x
x
x
x
x
x
x
x
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16.5
11.7
11.7 Landscape
8.3
5.8
13.9
9.8
10.0
17.0
14.0
11.0
11.0 Landscape
17.0

Overwrite
PDF

When checked, the PDF document in the IFS will be overwritten.
If unchecked, each PDF name created in the IFS will be appended with the date and
time.

Original
Spool

Affects what should happen to the spool file once it has been processed by the Monitor.
*NONE No action occurs on the spool file once it has been processed. It will remain in
a ready (RDY) status in the IBMi output queue.
HOLD

Once the spool file has been processed by the Monitor, it will be placed on
hold (HLD). This is the recommended setting. Spool files remaining in
ready status of a monitored output queue were not processed. To process,
hold the spool file and re-release to output the form. Periodically, the output
queue should be cleared.

DLT

Once the spool file has been processed by the Monitor, it will be deleted.

MOVE

Once the spool file has been processed by the Monitor, it will be moved to
another IBMi output queue. When selected, a list of all IBMi output queues will
be displayed. Select the queue where the original spool file will be placed.

PDF Properties Continued
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Output
Mode

Determines whether a PDF document is generated or how the spool file is burst to
produce PDF Files and IBMi print output. See Bursting Example.

Normal

The PDF document will be created based on the entire spool file. The
document will be saved to the designated location on the IFS. If email or
print properties are set, the PDF File will be emailed or printed
correspondingly.

Off

The PDF document will NOT be created. However, if the form is configured
to email, the PDF File will still be created.

Per Page

A PDF document will be created for each spool file page.
Example: For a 5 page spool file, 5 one page PDF documents will be
created. If the form is configured to email, 5 emails will be sent with a
single page PDF document attached.

<!field!>

The spool file will be burst based on data contained within a field created in
form design.
Example: If a field called <!Invoice#!> is created in form design and chosen
for output mode, the software will create a new pdf file each time data within
the <!Invoice#!> field changes. See Burst Example below.
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Burst Example – PDF Output
Bursting is the process of splitting a single (multiple-page) spool file, into several pages of
output. In this example, the output will be burst when a Spool File Field changes within the
spool file data.
A field called <!Invoice#!> was created in TLAForms Designer and chosen for output mode.
See PDF Properties. A six page spool file is generated from the IBMi and picked up by the
TLAForms Monitor. The monitor will create a new PDF document each time data within the
<!Invoice#!> field changes.
Notice the six page spool file is burst into three separate PDF documents due the change of the
invoice number data within the spool file. The PDF documents can be emailed to different email
recipients.
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Generating Email
TLAForms automatically emails the PDF documents. If the ‘Email From’ and ‘Email To’
properties contains an email address, an email will be sent.
Email properties such as Email To can come from data in the spool file, spool file attributes or
from an SQL statement. To use variable data in Email properties, right click in the
property field.

Email Options
Email Options are set by clicking, Tools>Advanced Options > Email Options Tab
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Email Properties
Email properties are set by clicking, Tools>Advanced Options > Email Options Tab

Email To

Email address to which the PDF document will be emailed. If the email address
does not contain a @ sign or a period, an error message will be sent to qsysopr.
The monitor will continue with the next spool file to process.
Note: To send the email to multiple recipients place a semi-colon between
Email addresses.

CC

Email address to which the PDF document will be emailed as a carbon copy.

BCC

Email address to which the PDF document will be emailed as a blind carbon copy.

Email From

Address to be emailed from. This also controls where replies would be sent.
Note: If the From Email address is blank, TLAForms will not attempt to send the
email.

Email Subject

Subject of email.

Body

This is the body or message of the email.

Additional
Attachment

Additional documents may be attached to the email. Click the
to select the document to be attached. Once saved the document is placed in the
following folder in the IFS: home/tlaform/emailattach
Attachments can be variable by right clicking in the additional attachment field and
selecting from Spool File Data, Spool File Attr, or SQL Statement. The variable
attachment must be manually placed in the IFS directory:
home/tlaform/emailattach.

All Email properties can be variable using Spool File Data, Spool File Attributes, or an SQL
Statement by right mouse clicking in any email property field.

Note: Before the email can be sent, the SMTP server must be configured within
TLAForms. See Global Settings–Email.
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Printing
TLAForms can print to PostScript printers defined on the IBMi. The software can also print to
any printer connected to a Windows Server or the local PC.
When printing to an IBMi PostScript printer, a device description is required. To create a
device, see Create Device Description.

NOTE: Before the form will print, a printer must be associated to the form.
By default, the printer is set to *NONE.

To select, change or display the printer, click Tools>Advanced Options> Printing Tab

Select the Refresh Printers button.
This will scan the IBMi for all PostScript printers. To scan for all available printers, IBMi and PC
printers, change Print Services to *All.
The results of the scan will be loaded into the Printer List.
If there are IBMi printers that do not appear in the list after Refreshing Printers, the printer is not
configured for postscript printing on the IBMi. See Create Device Description.
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Printing Properties
Printer

IBMi Postscript printers are displayed using the name of the device created for the
printer.
If there are IBMi printers that do not appear in the list after Refreshing Printers,
the printer is not configured for postscript printing on the IBMi.
See Create Device Description.

Windows Server printers are displayed using the following syntax:
Win: \\ServerName\PrinterName
Printers configured on a PC are displayed using the following syntax:
Win: PrinterName

Copies

Number of copies to be printed.
If copies is set to 0 (zero), TLAForms will automatically access the Copies
attribute of the spool file to determine the number of copies to print.

Drawer

Drawer from which stock will be selected from the printer.
Refer to your printer manual to obtain the correct location of the drawer being
used.
To print to the drawer using the attributes of the spool file, enter <!DRAWER!>

Variable
Printer

There are three ways to achieve variable printing.
1

Spool Data
The program that produces the spool file writes the printer name to the spool
file. Then create a field from the spool file data for the printer name.
Click Variable Printer>Right Click the printer field and select Spool Data to
select the printer name field that was created from the spool file.

2

Spool Attribute
The program that produces the spool file overrides one of the spool file
attributes such as user data or form type with the printer name.
Click Variable Printer>Right Click the printer field and select Spool Attr to
select the spool file attribute that contains the printer name .

3

SQL Statement
Create an SQL statement to retrieve the printer from an IBMi database file.
Click Variable Printer>Right Click the printer field and select SQL Statement
that will return the printer name.
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Output
Mode

Print
Services

Determines how print jobs are generated. Output mode can be used to burst
printing of a form to different printers, or to burst printing of a form into separate
print jobs.
Normal

The form will be printed based on the entire spool file.

Off

The form will not be printed.

Per Page

The spool file will be burst, and the form is printed based on each
page of the spool file. If a spool file consists of 5 pages, 5 separate
print jobs are generated.

Field Name

The spool file will be burst based on data contained within a field
created in form design. If a field called <!Invoice#!> is created in
form design and chosen for output mode, the software will create a
new print job each time data within the <!Invoice#!> field changes.

The Printer Services options allow for printers list to be populated based on where
the printer is defined.
*ALL

Displays all printers configured on the IBMi as PostScript,
printers defined on Windows Servers and printers defined
on the PC being used.

IBMi Postscript

Displays only printers configured on the IBMi as PostScript
printers.

Local Windows

Displays only printers configured on the PC being used.

Windows Network

Displays only printer configured on the Windows network.

Click Save

Note: In order to print the form to an IBMi printer, a PostScript printer is required.
Additionally, a Device Description is required. To create a device,
see Create Device Description.
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Burst Example – Print Output
Bursting is the process of splitting a single (multiple-page) spool file, into several pages of
output. In this example, the output will be burst when a Spool File Field changes within the
spool file data.
A field called <!Invoice#!> was created in TLAForms Designer and chosen for output mode.
See Printing Properties. A six page spool file is generated from the IBMi and picked up by the
TLAForms Monitor. The monitor will create a new print output each time data within the
<!Invoice#!> field changes.
Notice the six page spool file is burst into three print jobs due the change of the invoice number
data within the spool file. The printed output can be printed to different printers.
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Create Device Description
Use the following to create a device description on the IBMi for postscript printing.
NOTE: *IOSYSCFG authority is required.

From an IBMi command line:
Type STRPDM,
Press F10 (Command Entry)
Press F11 (Display Full)
Copy and Paste the CRTDEVPRT command shown below in the full command line.
CRTDEVPRT DEVD(PRINTNAME)
DEVCLS(*LAN) TYPE(3812) MODEL(1) LANATTACH(*IP)
PORT(9100) ATTACH(*DIRECT) FONT(011) FORMFEED(*AUTOCUT)
PRTERRMSG(*INFO) PARITY(*NONE) STOPBITS(1)
TRANSFORM(*YES) MFRTYPMDL(*HP5)
RMTLOCNAME('10.20.30.40')
SYSDRVPGM(*IBMSNMPDRV)
PUBLISHINF(*UNKNOWN *UNKNOWN *UNKNOWN *UNKNOWN *BLANK (*PCL *PS))
TEXT('TLAForms Device Description')

Change the following parameters:
DEVD

The name of the printer to be created on the IBMi.

RMTLOCNAME The IP address of the printer.
TEXT

The description of the Printer.

The printer will now appear in the TLAForms Designer once the Refresh Printers button is
pressed from the from Tools>Advanced Options> Printing Tab

Note: If the following error occurs, “Document Flavor not supported” when printing a
form, the device description is not configured properly.
Ensure that Publishing Information (PUBLISHINF) is set to *PS. This error will occur if
the printer is turned off and PUBLISHINF is set to *UNKNOWN.
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Global Settings
The Global Settings are available to make settings 'default' for PDF Preferences, Email, and
Notifications. The Email section is used to configure SMTP settings to allow TLAForms to send
emails. Notifications allow users to receive email notifications when an error occurs.
To modify these settings select; Tools>Global Values.

Global Settings - Preferences
IFS Path

Path for the Integrated File System (IFS) on the IBMi. This is the default path
where the PDF documents will be created.

Page Size

The page size for the created PDF document.

Overwrite PDF

not used.

Delete Spool

not used.

Create Fields

not used.

Show Margins

Shows a margin in the Forms Designer.
Top Measurements made in inches and tenths of an inch.
Left Measurements made in inches and tenths of an inch

Margins are used as a guideline within the designer and do NOT affect the printers margins.
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Global Settings – Email
The global email settings are used to configure TLAForms to send emails via your companies
SMTP server. The windows server(s) where the monitor is running routes the email to the
SMTP server. Your mail server must allow the windows server to send outbound mail.
Note: This setup may require assistance from your network administrator.

To modify these settings select; Tools>Global Values>Email tab.

Server Information
Outgoing Mail
Server (SMTP)

The Fully Qualified Domain Name (FQDN) or IP Address of your company
SMTP server.

Port:

Port for the Outgoing Mail Server (SMTP).

Logon Information
Username

User name for SMTP Authentication if required.

Password

Password for SMTP Authentication if required.

Use SSL

Check this box if your SMTP server requires Secure Sockets Layer (SSL)

Use TLS

Check this box if your SMTP server requires Transport Layer Security (TLS)

Click Save.
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Global Settings – Notification
The global notification setting is used to configure automatic email notifications when an error
occurs or when the TLAForms monitor is started or ended. Before setting up notifications, the
SMTP settings must be configured. See Global Settings–Email.

To configure Notifications select Tools>Global Values>Notification tab.

To

Email Address(s) where the notification is to be sent.

From

Email Address(s) from where the notification is sent from.

Events
Start

Send an Email to the To recipient(s) when TLAForms Monitor is Started.

Stop

Send an Email to the To recipient(s) when TLAForms Monitor is Ended.

On Error

Send an Email to the To recipient(s) when TLAForms Monitor encounters an error.

Click Save.
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Previewing the Form as a PDF
To preview the form as a PDF, select Tools>PDF Preview or press the

Note: When the PDF document is displayed, the zoom factor to 100% for the most
accurate representation of the form.

The Preview PDF file will be generated using sample data from the first record of the spool file.

TLAForms User Manual

Variable Data
Variable Data refers to any data on the form that may change when the form is created. For
instance, if the form has the text: Customer Name: ABC Company the text Customer Name:
will likely be static and appear every time the form is generated. Whereas the name ABC
Company may change each time the form is generated or on each page of a multi-page spool
file.
TLAForms can utilize three sources for variable data – Spool File Data, SQL Data which is
data retrieved from IBMi files, and Spool File Attributes which are the attributes of the spool
file associated with the form.
Actions can be created to show or hide objects based a particular condition, or replace data
based on user-defined criteria.

In this section the following four types of variable data will be discussed.
Spool File Data
SQL Data
Spool File Attributes
Actions
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Spool File Data
Forms use a spool file selected from an IBMi output queue. Fields are then created using the
position of data in the spool file (the position of the data is the line number, start column, end
column, and the number of lines). The fields are then placed on the form layout as text,
barcodes, and images. Fields can also be used to define PDF properties, printing properties
and email properties.

To access the spool file data, click the Add Text button
or Add Image
button.

, Add Bar Code button

or

From the properties window, click Spool Data.
The Spool Data – Field Configuration window displays the associated spool file on the left.
Fields can be created from the spool file or selected from the Created Fields Table and placed
on the form.
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Creating Fields
To create a field, click and drag to highlight data on the form. You can select multiple lines,
across columns and rows or entire section of the spool.

Click and Drag
to highlight
data to create a
field

Field Properties

Field Length

In the example, the company address information is highlighted. Notice that the highlighted area
extends beyond the data to ensure that longer address information will be captured when
subsequent spool files are output.

Field Properties
Field Name: Name assigned to the field created from the selection.
From Line:

Indicates the line number of the highlighted spool file data.

Number of Lines: Number of the lines included with the field. After creating a field, this
property is used to include multiple rows with the same field width. It creates a Multi-Line field.
Start Position: Column position of the first character of the field.
End Position: Column position of the last character of the field.

Click Save
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The field is added to the Created Fields table, and can be selected and added to the form as
Text, Bar Code or Image.
NOTE: When a field is selected and added to the fields data property, it will be displayed with the
following syntax: <!fieldname!>

NOTE: A multi-line field cannot be combined with other data when placing form objects.

Edit Existing Fields
To edit a field, select the field from the Created Fields table. Click Edit.

Select Field to
Edit

Click
Edit

If the selected field is in use, the only attributes that can be edited are the: from line, start
position, and the end position.
Click Save.

Note: If the field is in use, and you want to change the Field Name or the Number of
Lines, you must remove the field from the document, save the form by clicking File>Save.
Then return to the Field Configuration table to edit the field.
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Delete Existing Fields
To delete a field, select the field from the Created Fields table. Click

Select Field to
Edit

Click

If the selected field is in use, the field cannot be deleted.

Note: If the field is in use, and you want to delete the Field Name, you must remove
the field from the document, save the form by clicking File>Save.
Then return to the Field Configuration table to delete the field.
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Replace Spool Data
Replacing spool data is useful, and recommended, to verify the validity of the spool data fields
that have been created. Replacing spool data also allows you to visualize actions being used
on the form. See examples below.
To Replace Spool Data, click File> Replace SpoolData
Click the spool file from the list of files currently in the queue, click Select.
The data within the left potion of the screen will be changed to reflect the new spool file data.
Additionally, the spool file attributes will be changed.
Example – Replace Spool Data to Verify Fields
Spool Files can contain a variety of data and data at different locations within the spool file. If a
Multi-Line field has been created for the Ship To as shown, the field will contain 4 lines.
However, replacing the spool file data with another spool file might show that the Ship To field
needs to encompass 5 lines for the field instead of 4.
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Example – Replace Spool Data to Test Spool File Attributes
Actions can use Spool Attributes. For example;
If the spool file attribute Form Type is ‘ABC’, the ABC Company Logo will appear on the form.
If the spool file attribute Form Type is ‘ACME’, the Acme Company Logo will appear on the
form.
To test the Action, click Spool Data>Field Configuration, then click File>Replace Spool Data.
Choose a spool file with the Form Type to be tested.
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SQL Data
TLAForms can utilize SQL to retrieve data from files on your IBMi. The data retrieved from the
SQL statement can be used on the form as text, bar codes, or images. SQL statements can
also be used in the PDF properties, Printer properties, and Email properties.

Add SQL Statement
To Add SQL Statements, click Spool Data > SQL Configuration

The SQL Statement Configuration window will be displayed.

Select Add

The Select Statement area will be displayed.

Construct the sql statement to retrieve data from an IBMi file. See SQL Properties.
Click Save.

TIP: It may be helpful to name the sql with an sql_ prefix to provide clarity when designing the form.

101

102

TLAForms User Manual

SQL Properties

SQL Name

Specify a name for the SQL statement being created. When using SQL Data
with a form object or any property, the SQL Name is used.

Library

Identifies the library of the file that the SQL statement will access.

File

Identifies the file that the SQL statement will access.

Where

Identifies the field within the file used for comparison.

Operand

EQ
NE

Compare Field

The compare field can be Constant Data, Spool Data, or a Spool File
Attribute.

Equal
Not Equal

The field from the spool file that contains the value to be used when retrieving
the field from the IBMi file. Select the spool data button to select the field
from the spool file.
To use a Spool File Attribute, Right Click and select Spool Attr.
To compare for blanks, leave the compare field empty.

Return Field

The field from the IBMi file to be returned when the SQL is processed.

NOTE: When using an SQL Statement it will be displayed with the following syntax:
<%fieldname%>

Tip: Once created, test the SQL statement using a Text Object on the form.
See Test SQL Statement.
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Edit SQL Statement
To Edit an SQL Statement, click Spool Data > SQL Configuration

The SQL Statement Configuration window will be displayed.

Select the SQL Statement to change. Click the Edit button.

The Select Statement area will be displayed.
Selected SQL in use.

Make any modifications to the SQL Statement.
Click Save.

Note: If the Selected SQL in use message is displayed, certain aspects of the SQL
Statement will not be editable.
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Delete SQL Statement
To Delete an SQL Statement, click Spool Data > SQL Configuration

The SQL Statement Configuration window will be displayed.

Select the SQL Statement to change. Click the Delete Button

If the SQL Statement is used on the form or used in any property, the following message will be
displayed.

Select OK.
In order to delete the SQL Statement, remove the SQL from the form design or any form
property. Once removed, save the form, then return to SQL configuration and Delete the
statement.
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Copy SQL Statement
To Copy an SQL Statement, click Spool Data > SQL Configuration

The SQL Statement Configuration window will be displayed.

Select the SQL Statement to change. Click the Copy Button.

The Select Statement area will be displayed.

Enter an SQL Name for the new statement to be created from the original statement. Make any
changes to the statement.

Click Save.
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Test SQL Statement
To Test an SQL Statement, click Spool Data > SQL Configuration

The SQL Statement Configuration window will be displayed.

Select the SQL Statement to test. Click the Test Button.

The following window will be displayed with the results of the SQL Statement.

If the SQL Statement does not return any data, the following window will be displayed.
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SQL Example – Variable Email Address
In this example, a sql statement will be created to retrieve an Email address from the IBMi file
using data from the spool file. The Email address that is returned from the sql statement will be
used as the email address when the form is delivered.
1. Create a field called company from the spool file data. Spool Data>Field Configuration.

Create a field called company.
The data is: ABC Company

2. Create an SQL statement to retrieve the Email address from tlaform/CUSTFILE.
Select Spool Data>SQL Configuration.

Construct the SQL statement to select the EMAIL_TO (return field) from the
TLAFORM/CUSTFILE file where the COMPANY field in the IBMi file is equal to the company field
from the spool file.

To select the company field from the spool file select the Spool Data button. When the spool file
field is placed in the Compare Field it will be delimited with <! !>.
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3. Use the SQL statement in the Email To address, thus creating a dynamic email.
Select Tools>Advanced Options then click the Email Options Tab

Right Click

Right Click in the To… field, select Insert SQL

The SQL statement Configuration window is displayed.

Click the sql_Email statement, press Select.
The To… Address will now contain <%sql_Email%> sql statement.
Each time a spool file is processed, the Customer Name from the spool file will be used to
retrieve the customers Email address from the custfile.
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Spool File Attributes
Spool Attributes refer to the properties of the IBMi spool file for which a form is designed. These
attributes can be used on the form as a value for Text, Bar codes and Images. Spool Attributes
can also be used as values with Printing Options, PDF Output Options, Email Options, Actions
and when creating SQL Statements.

Available Spool Attributes
Spool Attr

TLAForm Attribute

FormType
UserData
UserText
JobName
JobNumber
SpoolName
SpoolOutq
SpoolUser

<!FORMTYPE!>
<!USERDATA!>
<!USERTEXT!>
<!JOBNAME!>
<!JOBNUMBER!>
<!SPOOLNAME!>
<!SPOOLOUTQ!>
<!SPOOLUSER!>
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Spool File Attribute Example – Text Object
This example describes how to add a Spool File Attribute (Form Type) on a form as a text
object.

This is useful when designing a form where a spool file attribute is used as an action to indicate
which objects are output.

Click the Add Text

button in the toolbar. The Text properties window will be displayed.

Right Click

Right Click in the Data Field. Select Spool Attr>FORMTYPE

The data field will now contain <!FORMTYPE!> Select OK to place the text object on the form.
The form type from the spool file will be displayed on the form.
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Spool File Attribute Example – Variable Printer
This example describes how to use a Spool File Attribute (Form Type) on a form to control
where the form is printed.
Note: The program that produces the spool file overrides the printer files’ form type with the
printer name.
For example:

OVRPRTF FILE(INVOICE) FORMTYPE(PRT_ACCT)
or OVRPRTF FILE(INVOICE) FORMTYPE(PRT_SALES)

Notice there are two INVOICE spool files in the tlaform/sampleform output queue.

Select the Printing Tab from the properties pane.

Check

Right Click

Check the Variable Printer box. Right Click in the Variable Printer field.
Select Spool Attr>FORMTYPE.
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The Spool File Attribute of form type is now used in the Variable Printer field as shown below.

Save the Form.
When the form is processed by the monitor, the form will be printed to the printer device
retrieved from the Form Type Attribute.
In this example, (shown on the previous page) the first invoice will be printed to PRT_ACCT and
the second invoice will be printed to the PRT_SALES printer.

Note: In order to print the form to an IBMi printer, a PostScript printer is required.
Additionally, a Device Description is required.
To create a device, see Create Device Description.
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Actions
Actions allow objects to be shown or hidden, and can be used to replace data in the object with
different t data. Actions can be applied to any object on the form with the exception of Overlays.
Actions can be tested or visualized by either scrolling through the spool file pages or by
replacing spool data. Scrolling through the pages of the spool file tests the action against data
on the subsequent pages of the spool file. Replacing Spool Data tests actions against data in a
different spool file, or Spool Attributes from a different spool file.

Add Action
To Add an Action, click Spool Data > Action Configuration

Click Add.

The Action Event area will be displayed.

Construct the Action Event to control how objects are output to the form. See Action Properties.
Click Save.
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Action Properties
Action Name

Name assigned to the action. When an Action is used on an object, or groups
of objects, the Action name is used.

Action

Show

If the action is evaluated as true, the object will appear on the form.

Hide

If the action is evaluated as false, the object will not appear on the
form.

Replace

If Replace String is selected, the spool data in the Spool Field
(Factor 1) will be replaced with the data in Factor 2.

Spool Field
(Factor 1)

Specifies the Spool Data Field used for the comparison. Spool Field refers to
fields created when Selecting Data from the Spool File.
Spool Attributes and SQL Statements can also be select.

Operator

EQ
NE
CT
GT
LT

Factor 2

Value for comparison. The comparison value can be a constant or from a
spool file field.

Equal
Not Equal
Contains
Greater Than
Less Than

To compare against a blank field use *blank, *blanks, or leave the field blank.

Note: The action can be applied to any object on the form with the exception of overlays.

TIP: It may be helpful when to name actions with an act_ prefix to provide clarity when designing
the form.
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Edit Action
To Edit an Action, click Spool Data > Action Configuration

The Action Configuration window will be displayed.

Select the Action to change. Click the Edit button.

The Action Event area will be displayed.
Selected Action in use.

Make any modifications to the Action Event.
Click Save.

Note: If the Selected Action in use message is displayed, certain aspects of the Action
Event will not be editable.

115

116

TLAForms User Manual

Delete Action
To Delete an Action, click Spool Data > Action Configuration

The Action Configuration window will be displayed.

Select the Action to change. Click the Delete button.

If the Action Event is used on any object, the following message will be displayed.

Select OK.
In order to delete the Action Event, remove the Action from all Form objects and properties.
Once removed, save the form, then return to Action configuration and Delete the event.
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Copy Action
To Copy an Action, click Spool Data > Action Configuration

The Action Configuration window will be displayed.

Select the Action to change. Click the Copy Button.

The Action Event area will be displayed.

Enter an Action Name for the new Action to be created from the original. Make any changes to
the Event.

Click Save.
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Group Action
An action may be applied to several objects by selecting the objects, then right mouse click.
Select Group Action and choose the desired action.

Apply Actions
All actions on a form may be enabled or disabled. This is helpful when designing forms to
ensure validity of the actions.
To Enable/Disable Actions, select View>Apply Actions
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Action Example – Output Barcode on Page 1
In this example, we have a multiple page spool file that we want to create a PDF document
from. However, we only want to output a barcode on the first page of the document.
1. Create an action called act_Page1 as shown below.

The act_Page1 action will show an object if the Page# field from the spool file is equal to 1.

2. Add the action to the barcode. Edit or Add a barcode to the form.

Select the Action act_Page1 as shown. Select OK.
Note: To add the Action to multiple objects, highlight the objects, right click.
Select Group Action and choose the desired action.
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3. Test the action as shown.

The form is currently displaying page 1 of 4 as shown above. Notice the barcode is SHOWN.

Click Page UP to display page 2 of the spool file.

Notice the barcode is no longer displayed.
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Transfer Forms from IBMi
To transfer a forms from one IBMi to another; execute the TLAForms Designer on the machine
that contains the form to be transferred.

Note: The version of the TLAForms software must be the same on both IBMi machines.

From the Form Designer, select File>Transfer Forms

The Transfer Forms window will be displayed.

Select the Form(s) from the table.
Enter the Remote IP address of the target IBMi to which the form(s) will be transferred.
Enter IBMi User and Password.
Click Transfer.
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TLAForms Monitor
The TLAForms Monitor is responsible for generating the form. The form can be printed,
emailed, and archived to the IFS as a PDF document. The Monitor is intended to be executed
on a Windows Server; however it may be run on any Windows PC.
The monitor continuously reads the tlaformdq data queue looking for entries. An entry is placed
in the data queue when (1) the data queue is attached to an IBMi output queue and (2) a spool
file becomes ready in that queue.
When the monitor gets an entry from the data queue it will evaluate the spool file name, output
queue, and library against forms that have been designed within the TLAForms Designer. If a
match occurs, the monitor grabs the data from the spool file and creates the form. If they do not
match, the monitor reads the data queue for the next entry.
Additional spool files will not be processed until the previous spool file has been used to create
the form. To perform simultaneous processing, resulting in faster throughput, the Monitor can
be started multiple times. This will allow multiple spool files to be processed simultaneously. If
running several TLAForms Monitors on a single Windows Server, ensure that the server has at
least 8 gb of Ram with a higher end processor. It is not recommended to run more than four
monitors on one server. See System Requirements.
The TLAForms Monitor is not a windows service program. It is an application that is intended to
be started from the Windows desktop. However, the Monitor can be executed from a scheduled
task.

To execute the TLAForms Monitor form a windows desktop see:
TLAForms Monitor – Manual Start.
To execute the TLAForms Monitor as a scheduled task see
TLAForms Monitor – Scheduled Task

Once the Monitor is started, the Monitor Management Console can be used from an IBMi
command line to manage the monitor.
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TLAForms Monitor – Manual Start
From the Windows desktop, double-click the TLAForms Monitor icon.
The TLAForms Monitor Sign on will be displayed.

Enter the IP Address of the IBMi.
Enter your IBMi User Name and Password.
Click Login.
The Monitor window will be displayed.

Start / Stop Button
Used to start/stop the
monitor without ending the
application.

Attached Queues
The IBMi output queues
that are currently being
monitored

Processed
The number of spool files
that have been processed.

Status
Displays the spool file and
process function.

The Forms Monitor displays the Attached Output Queues as well as indicates the number of
forms processed. When a spool file is being processed, the status area will indicate the spool
file and the function that is being performed.
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Output Queues
The output queues listed in the table are IBMi output queues configured with the TLAFORMDQ
data queue. To add the tlaformdq to an IBMi output queue, use the following command:

CHGOUTQ OUTQ(MYQUE) DTAQ(TLAFORM/TLAFORMDQ)
If the monitor application is started and a change was made to an IBMi output queue, click the
refresh icon
to refresh the list.

The monitored output queue should not be associated to a started writer on the IBMi.

Event Log
The event log will contain an entry for each spool file that has been processed by the monitor.

Click Event Log.
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The Event Viewer will be displayed.

By default the Event Log is sorted by Date and Time. However, the event log can be sorted by
clicking on any Column Heading.
The event log does not get cleared when the TLAForms Monitor is shut down. To clear the log,
click the Clear button.

Function
For each spool file that is processed, up to three Functions may be logged. The three functions
are; Printing, PDF Create and Email.
The printing function may be listed as:
PS Print

Static IBMi postscript print.

Var Print

Variable IBMi postscript print.

Win Print

Static windows print.

Var Win Print

Variable windows print.

Completed
The completed column will be true or false. If false, a function did not successfully complete.
See the details column for more information.
Tip: Click the Completed column heading to group all false completions together.

Note: If no events are logged, ensure that you are authorized to the event file. The event file is
stored in the C:\ProgramData\TLAFORM folder named formEvents_10.20.30.40.txt
where 10.20.30.40 is the IP Address of the IBMi.
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TLAForms Monitor – Manual Shut Down
To shut down the TLAForms monitor, click the ShutDown button as shown below.

The following message will be displayed.

Click OK.
The status will be change to Stopped. Forms will not be generated. If configured spool files are
sent to a monitored output queue, these spool files will be processed when the monitor is
started.
The following message will be sent to the qsysopr message queue.
From…
QPGMR
02/03/15
10:04:21
TLAForms Software has encountered a problem. Disconnect request
received, connection terminated. Error on Running command

The monitor application will be exited.

TLAForms User Manual

TLAForms Monitor – Scheduled Task
This section describes how to automatically start the TLAForms Monitor application as a
scheduled task to be performed “At Power Up” on a Windows Server.

Note: When the TLAForms Monitor is started as a Scheduled Task, the monitor window
will NOT be displayed. To manage the Monitor See:
TLAForms Management Console.

From the Windows Server or PC, select Start Control Panel > Administrative Tools
Task Scheduler

The task Scheduler will be displayed.
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Right click on Task Scheduler, select Create Basic Task.

The Create Basic Task Wizard will be displayed.

Enter the name of the task that you wish to create.
In this example “TLAForms Monitor – Start Up” will be used.
Select Next.

TLAForms User Manual
The Task Trigger window will be displayed.

When do you want the task to start, select “When the computer starts”
Select Next.

The Action window will be displayed.

For Action, select “Start a Program”
Select Next.
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The Start a Program window will be displayed.

Program/script: Enter the full path where javaw.exe is located.
Select Browse.
Navigate to the Java folder. Typically located in the Program Files (x86) Folder.
Select the jre7 (or higher) folder, then the bin folder. Select javaw.exe from this folder.
Click Open, the path of javaw.exe will be placed in Program/script field.

Add Arguments: Enter the statement as shown below in the Add arguments field.
-jar “C:\Program Files (x86)\T.L. Ashford & Associates\TLAForms\Monitor\TLAForms_Monitor_Interface.jar”
“100.100.100.100“ “username“ “password“

If you copy and paste this instruction into the Add arguments field, re-type every (“) character.
Where:

“100.100.100.100”
“username”
“password”

IP address of the IBMi
IBMi user name
IBMi password

Note: The argument MUST be exact. If the Monitor does not start, this is the first place to check.
Right click the Task, select Properties> Actions > Edit.

Select Next.
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The Summary window will be displayed.

Check “Open the Properties dialog for the task when I click Finish”
Select Finish.

The Properties Dialog will be displayed.

Check Run whether the user is logged on or not.
Check Run with highest privileges.
Select OK.
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The user account window will be displayed.

Enter your user name and password for the Windows Server.
Select OK to be returned to the Task Scheduler.
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Verify Scheduled Task
The Scheduled Task will be listed in the Task Scheduler in READY Status.

Right click on the task TLAMonitor task, select RUN.
Press F5 to Refresh.
The task should now be running. The Monitor will NOT be dispalyed.

To verify that the monitor is active, from the IBMi: type
If the connection does not initially appear, press F5.

tlaform/tlamonitor

To manage the TLAForms Monitor: See TLAForms Management Console.

If the monitor does not start, check the action tab. Right click the Task, select Properties>
Actions>Edit. Verify the program script and arguments are correct.

If the IBMi is scheduled to IPL or backup, add another trigger to this task to start the monitor
on a schedule. See Add a Trigger to the Scheduled Task.
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Add a Trigger to the Scheduled Task
The TLAForms monitor requires the IBMi to be active and not in a restricted state. Most IBMi
shops have nightly, weekly, or monthly scheduled tasks that will back up the system, IPL the
system, or perform some other routine maintenance functions. When this occurs, TCP/IP
server jobs may end and subsystems could be shut down.
TLAForms monitor requires that TCP/IP is active and that the *database, *dtaq, and *file servers
are started. Additionally, the QUSRWRK subsystem must be active.
Therefore, before one of these scheduled tasks occurs on the IBMi, the TLAForms monitor
should be ended by executing: call tlaform/tlaformend
This will ensure that all TLAForms jobs on the IBMi are ended normally. Spool Files will not be
processed.
Once the IBMi is back to normal operations, the TLAForms monitor should be restarted.
To restart the monitor within the “Start-Up” scheduled task, add a trigger to the scheduled task.

Task scheduler

Right Click the TLAForms Monitor task, select Properties.
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Select the Triggers Tab, Click New.

In this example, the task will be started at 12:00 AM every night. A scheduled task should be
added on the IBMi prior to 12:00AM to end the monitor. See IBMi Scheduled Task.
Select OK.
The Trigger window will be displayed.

The scheduled task now has two triggers. Select OK.
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IBMi Scheduled Task

A scheduled task should be added on the IBMi prior to the scheduled task time to end the
TLAForms monitor. For this example, IBMi job scheduler was used to call the tlaformend
program.
The tlaformend program will close all active instances of the TLAForms monitor.

From an IBMi command line type: ADDJOBSCDE
Add Job Schedule Entry (ADDJOBSCDE)
Type choices, press Enter.
Job name . . . . . . . . . . . . > *JOBD
Name, *JOBD
Command to run . . . . . . . . . > CALL PGM(TLAFORM/TLAFORMEND)
Frequency . . . . . . . . . . . >
Schedule date . . . . . . . . . >
Schedule day . . . . . . . . . . >
+ for more values
Schedule time . . . . . . . . . >

*WEEKLY
*NONE
*ALL

*ONCE, *WEEKLY, *MONTHLY
Date, *CURRENT, *MONTHSTR.
*NONE, *ALL, *MON, *TUE...

'23:45'

Time, *CURRENT

Notice the tlaformend program will be executed every night at 23:45 (11:45 pm).
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TLAForms Management Console
The TLAForms Management Console allows users to see the status of the TLAForms
Monitor(s) from an IBMi command line. This tool queries any windows server or personal
computer for all instances of the TLAForms Monitor.
This tool is useful when the TLAForms Monitor is started as a scheduled task, as the monitor
window will not be displayed when started as a scheduled task on a windows server/pc.

To start the Management Console:
Type:

TLAFORM/TLAMONITOR from an IBMi command line

The following screen will be displayed.

8/11/15

TLAForms
Management Console

08:03:02

Type options, press Enter.
1=Start 3=Stop 4=Shutdown
Opt
_

User
QPGMR

Win IP Address
198.4.83.2

Status
Started

Processed
000010

Submitted
Date
Time
08/11/15 09:02

Bottom
F3=Exit F5=Refresh
F11=Clear Event Log

F7=Shutdown ALL

F8=List Queues

F10=Display Event Log

The Management Console is used to manage TLAForms Monitor connections. The Monitor
must be executed on a windows server or a PC. Once a monitor connection is active, the
TLAForms monitor can be used to verify the status of the monitor, stop the active instance and
start the active instance of the monitor.
Bottom

.

F3=Exit

F5=Refresh

F11=Clear Event Log

F7=Shutdown ALL

F8=List Queues

F10=Display Event Log
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In the window on the previous page, one instance of the TLAForms monitor is running. The monitor was
started on a windows server / PC with an Internet address (IP) of 198.4.83.2. The monitor was started
by user QPGMR. Ten Spool files have been processed and the Monitor was started on 8/11/15 at 09:02.

Options
Start

Place a 1 next to an instance of a Monitor that is currently at and Ended status.
This will start that instance of the Monitor.
Note: The Monitor must be executed from a windows server or a PC for it to be available
in the Management Console.

Stop

Place a 3 next to an instance of a Monitor connection that is currently in a Started
status. This will end that instance of the monitor. Spool files will NOT be processed and
forms will not be created using this instance of the Monitor.

Shut Down

Place a 4 next to an instance of the Monitor. Once the Monitor is shut down, the
Monitor must be executed from a Windows server or a PC.

Function Keys
F3

Exit the Management Console.

F5

Refresh the Management Console. If spool files are being processed by the
TLAForms Monitor on the Windows Server/PC, the processed number will change.

F7

Shut down ALL active Monitors. If all monitor(s) are shut down, spool files will not
be processed and forms will not be created. If executed, the TLAForms monitor
must be started on the Windows Server or PC.
To shut down all active monitors from a program or a scheduled task, execute
call tlaform/tlaformend .

F8

List Queus will list all IBMi output queus that are being monitored by TLAForms.
A monitored output queue is any queue that is configured with the tlaform/tlaformdq data
queue.
Press F6 to add an IBMi output queue to be monitored.
Place a 4 next to a queue to remove IBMi output queue from being monitored.
NOTE: A monitored output queue should not have a started writer.

F10

Display Event Log will display all events that have occurred from all instances of
the Monitor. Events such as PDF created, Printing, and Emailing will be listed in the event
log. The log information is contained in the tlaform/tlaeventpf physical file on the IBMi.

F11

Clear Event Log will clear all monitor events.
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Trouble Shooting
This section indicates common issues that may arise when printing, sending emails, and
creating PDF documents. Additionally, there is a general section that ay helps when
troubleshooting common software questions and errors.

Trouble Shooting - Printing

Error

Solution

Document Flavor not supported

Ensure that Publishing Information (PUBLISHINF) is set to *PS.
This error will occur if the printer is turned off, or has an error and
PUBLISHINF is set to *UNKNOWN.
See Device Description

Error Printing
TLAFORMS: {PRT_NAME}, Service
cannot be null
Error on Printing
SPOOLFILE/OUTQ/OUTQLIB
command
TLAFORMS: {PRT_NAME},
CPF2702 Device description
PRT_NAME not found.
Error on Printing
INVOICE/SAMPLEFORM/TLAFORM
command

The Windows Printer does not exist or is incorrect.
{PRT_NAME}
1. Install the Windows Printer on the server where the
monitor is running.
2. Make sure the Windows printer name is correct.

The form is set to use a variable printer, and the printer does
not exist on the IBMi.
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Trouble Shooting - Email

Error

Solution
If using Symantec, change settings on the tab shown below.
UNCHECK Enable Internet Email Auto-Protect

To Fix error,
Uncheck Enable
Internet Email
Auto Protect

Couldn't connect to host, port:
secure.emailsrvr.com, 25; timeout -1
Network is unreachable: connect

Make sure the file exists:
No authentication mechanisms
supported by both server and client

C:\ProgramData\TLAForm\emailprop.txt
and has:
mail.smtp.auth=false
Invalid username or password for the SMTP server.

535 5.7.8 Error: authentication failed:

From within TLAForms Designer, edit an existing form select
Tools>global Setting> Email tab and ensure that the user name
and password are correct. See Global Settings-Email.
Invalid SMTP port.

Couldn't connect to host, port:
From within TLAForms Designer, edit an existing form select
secure.emailsrvr.com, 26; timeout -1:
Tools>Global Setting> Email tab and ensure that the port is
correct. See Global Settings-Email.
Connection timed out: connect
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Couldn't connect to host, port:
test.smtp.com, 25; timeout -1:
test.smtp.com

Could not connect to SMTP host:
secure.emailsrvr.com, port: 25:
Unrecognized SSL message,
plaintext connection?

Could not connect to SMTP host:
secure.emailsrvr.com, port: 25:
Unrecognized TLS message,
plaintext connection?

Invalid outgoing mail server (SMPT)
From within TLAForms Designer, edit an existing form select
Tools>global Setting> Email tab and ensure that the port is correct.
See Global Settings-Email.
SSL is checked, but the SMTP server does not require SSL
authentication.
From within TLAForms Designer, edit an existing form select
Tools>Global Setting> Email tab and uncheck SSL. See Global
Settings-Email.

TLS is checked, but the SMTP server does not require TLS
authentication.
From within TLAForms Designer, edit an existing form select
Tools>Global Setting> Email tab and uncheck TLS. See Global
Settings-Email.

Invalid from address on the form.

Invalid Addresses: 550 5.1.0
<noreply@tlashford.com>:
Sender address rejected: User
unknown in relay recipient table

The email from address is not a valid address for your SMTP
server.
From within TLAForms Designer, edit the form, select
Tools>Advanced Options> Email Options tab and ensure that the
From address is able to send outgoing emails through your SMTP
server. See Email Options.

Invalid To email address.
Invalid Addresses: 504 5.5.2
<noreply@tlashford>:

Not a fully qualified to email address. Missing the .com extension
or an @ character.

Recipient address rejected: need
fully-qualified address

From within TLAForms Designer, edit the form, select
Tools>Advanced Options> Email Options tab and ensure that the
From address is correct. See Email Options.

Email To address has .com.
Error on Email command
null Error on Email command

From within TLAForms Designer, edit the form, select
Tools>Advanced Options> Email Options tab and ensure that the
From address is correct. See Email Options.
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Trouble Shooting – Create PDF Documents

Error

Solution

Java.net.connectionexception: connection
refused: connect

The TCP/IP host server *file is not active.

Error on Make Dirs command

java.net.ConnectException: Connection
refused: connect

strhostsvr *file

The TCP/IP host server *file is not active.
strhostsvr *file

Error on path setup command
TLAForms Software was unable to create the The TCP/IP host server *file is not active.
PDF.
Error on Create PDF command

strhostsvr *file

com.ibm.as400.access.ExtendedIOException: The PDF document in the IFS is in use and the form
Sharing violation occurred.
is configured to overwrite the existing PDF
Error on path setup command
TLAFORMS: {Lexmark Pro910 Series},
Printer is not accepting job.
Error on Printing
INVOICE/SAMPLEFORM/TLAFORM
command

document.
Printing to a windows print driver that has been
installed on the Windows server, but the printer does
not exist.
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Troubleshooting – General

TLAForms Software has
encountered a problem.

This is a normal message indicating that the TLAForms monitor
was ended.

Disconnect request received,
Connection terminated.
Error on command

Selecting an output queue to create
a new form and get the error,
CPF3429: spool file cannot be
configured.

The spool file that has been selected does not have a device
type of *SCS.
Re-create the spool file using the OVRPRTF command with
a device type of *SCS.
OVRPRTF FILE(MYFILE) DEVTYPE(*SCS)
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Copy, 17
Create New, 15
Delete, 19
Edit, 16
Generate, 77
Objects, 15
Rename, 18
Save, 16
Global Settings, 89
PDF Output, 89
Graphics, 43, 44
Add, 43, 44
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Import, 46
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Human Readable, 29
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Lines, 65
Lock, 71
MOD10, 40
MOD43, 41
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Page Size, 89
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Print, 84
Print Preview, 92
Printer, 84
Ratio, 29
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Rename, 18
Save, 16
Signing On, 125
Spool File, 95
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Test Printing, 73, 84
Text, 23
Add, 23
Edit, 24
Zoom, 71
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Contact T.L. Ashford
T.L. Ashford & Associates
626 Buttermilk Pike
Crescent Springs, KY 41017

Phone:
800.541.4893 (toll-free)
859.291.7555

Fax:
859.291.1804

Internet:
www.tlashford.com
tech@tlashford.com
sales@tlashford.com
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